Investigating issue with SSL connectivity

Incident Report for Tweakwise

Resolved

We have deployed a new SSL/TLS certificate signed by the GlobalSign root Certificate Authority, which has been trusted across systems and platforms for a longer period. Based on our monitoring, all previously affected customer integrations are now successfully executing requests.
Posted Aug 07, 2025 - 16:50 CEST

Identified

Earlier today we deployed a new SSL/TLS certificate signed by the Sectigo root Certificate Authority. Although this root CA is trusted by all modern operating systems and browsers, we found that a subset of customer integrations did not yet include this root certificate, causing TLS handshake failures.
To restore connectivity for everyone, we rolled back to the previous certificate chain. We are now obtaining a replacement certificate from an alternative CA whose root certificate has been trusted for a longer period. Once validated, we will deploy the new certificate.
Posted Aug 07, 2025 - 15:08 CEST

Investigating

We are currently investigating issues related to an updated SSL certificate. We are reverting the update and will keep posting updates here.
Posted Aug 07, 2025 - 12:38 CEST
This incident affected: Frontend API.